cancel
Showing results for 
Search instead for 
Did you mean: 

The selected object is not valid for modeling

Creator
Creator

 

Hello everyone,

 

I am having some trouble with the modeling scope and several questions. I can not set the modeling scope for the files avilable to me, which are organized in .co folders (Attachment1 below). 

Loading these files into Process Sim causes them to appear, but the Set Modeling Scope button turns grey and can't be used. My understanding is that these files need to converted to .cojt, otherwise the Kinematics function will be locked. I then convert the .jt file  to .cojt using TxJt2Co.exe present in the Tecnomatix folder, which seems to have been successful (Attachment2). The results are a log and xml file as well as the desired .cojt folder, whose contents are Attachment3. 

I then tried to load my load the converted file into PS once through the Convert and Insert CAD Files (which I don't think I should have done) and then seperately by defining component type and then using Insert Component. 

The final attachment shows the error message generated in PS when clicking the Set Modeling Scope button.

 

So much to my proceedings. Here are some additional questions I have:

1) What is the difference between using the command line based (TxJt2Co.exe) converter and the CAD-Converter inside of PS? The latter obviously is much simpler to use, but I have already converted to my desired filetype and therefore believe that inserting the component is the correct way to go.

 

2) Once my errors are sorted out, will it be possible to convert and insert multiple components at once? The use of the wildcard asterisk was not succesful in the command prompt, although its use should be the same as in the Linux shell that I am used to.

 

Please include any corrections and false assertions of mine below! Thanks for your time,

Kind Regards

[Edit]:Forgot to attachCat Happy

 

2 REPLIES

Re: The selected object is not valid for modeling

Siemens Phenom Siemens Phenom
Siemens Phenom
Hi
That you cannot model .co is normal behavior.
You have to decide: if Robcad-data (.co) is needed, then Robcad is your modeling tool.
If Robcad is not relevant anymore, you might upgrade your whole library.

Tx2co is not the right tool.
Instead use for single comp:
upgradetoversion -comp mycomponent.co -co2jt
For whole library:
upgradetoversion -dir mylibrary -co2jt

PD and PS also provide a GUI-Tool, not sure about exact name, but I think it's "Upgrade prototype to version"
Keep in mind that your PS .psz refers to your .co. You might break your studies.
If you have an eMServer environment and you use the internal upgrade mechanism, it will also update the reference from .co to .cojt.

Re: The selected object is not valid for modeling

Creator
Creator

@GuidoDamm

Thanks for your insights. I am having some difficulty converting the .co files still using the command you recommended, but the errors are now in connection to the registration of .dll files and fall outside the scope of PS and this forum. Once this problem is solved, I will see whether or not the original study becomes faulty or not.

 

Getting closer and closer to the solution, thanks to you. ;-)

 

Regards