cancel
Showing results for 
Search instead for 
Did you mean: 

error when importing jt file

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

Hello,

 

when i try to import a jt file i get the following error:

"The application can't import the XML file.

The file is not valid for the following reason: XML parsing error: "Access is denied.", line number=1, column=0."

JT Import Error.JPG

i have PS 10.1, cad translator v2.9.1, all rights to everyone on system root and on install folder.

it is a client-server arichitecture, and the import doesn't work for either the administrator or other users.

Any ideas why it won't work?

 

Thanks.

3 REPLIES

Re: error when importing jt file

Siemens Genius Siemens Genius
Siemens Genius

Hi,

 

Does the file your importing reside on the sysroot?  From the image it looks like it is in C:\Temp.  If it is not on the system root, which every client has access to other users will not be able to see it.

 

When importing CAD data an xml is wrote inside the folder containing the .jt file.  I think this is where the problem is.  The system cannot write in or create the xml file under the folder.

 

You should validate FROM the eMServer machine you can browse to and write to the location where the CAD data is going.

 

Also note that where ever you place the CAD data is where it must stay once it is imported, since the path to the .cojt folder is included in the database for that prototype.

Re: error when importing jt file

Siemens Genius Siemens Genius
Siemens Genius

Also note, that if you click on the link in the dialogue box to open the log file it will tell you the command line that is running in the background, for example:

 

The command line:
TxConvert2Co.exe D:\Sysroot\Libraries\NX_Data\Product\1l112395.geo_fin001.027999.prt -cojt -extIdMod 1 -dest D:\Sysroot\Imports-Exports -output rl112395_geo_fin001_027999.xml -emsClass PmCompoundPart;PmPartPrototype;PmPartInstance -l D:\Sysroot\Imports-Exports\TxConvert2co_rl112395_geo_fin001_02799920140725_081028.log

 

Here you can see one of the outputs is an xml file, which is used for importing the object into the project after the convertion is complete.  It can also be used to import the data into other projects.  the xml should be written to the same location where you are placing the converted file.

Re: error when importing jt file

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

Thanks for the tips, i have tried them out, but finally an eMS reinstall solved the problem.