cancel
Showing results for 
Search instead for 
Did you mean: 

insert own model as a part or resource

Pioneer
Pioneer

Hello,

I am using Tecnomatix v13.0.2. 
I am using NX10. 

I made a solid model in NX, I saved it as "*.jt" file. 
They opened a folder gave it a name "*.cojt". Then put "*.jt" in "*.cojt" file. 
After using insert component command in tecnomatix. I got an error about defining object.

I defined the component as ToolPrototype". but it does not work. object has been created but my part is not seen here. 

Can you tell me how can I add my own part to tecnomatix. 

Thanks.

Burpee.

5 REPLIES

Re: insert own model as a part or resource

Siemens Legend Siemens Legend
Siemens Legend

Hi,

 

After you defined your component using "Define Component Type", your *.cojt folder includes a "TuneData.xml" file.

Afterwards, use "Insert Component From File" to load your previously defined component into your study. (select the cojt).

 

Best regards

Patrick

 

Re: insert own model as a part or resource

Pioneer
Pioneer

Sorry Patrick

I did everything as you told be. but still my part's 3D contents does not seen in graphic viewer. 

Its my first time that i created a part in nx and I am trying to open in tecnomatix. 
I added the file here. 

Thanks.
Burpee


Re: insert own model as a part or resource

Siemens Genius Siemens Genius
Siemens Genius

I downloaded your .cojt file and tried to load just the .jt into our visualization application.  It loads (shows up in the tree), but there is nothing in the graphics viewer.  The size of the .jt file is 3KB.  You may want to try saving the .jt from NX again.

 

Try saving it from NX as a monolithic JT.

 

Re: insert own model as a part or resource

Pioneer
Pioneer

Ah, well. it goes still wrong. 

I created a new and basic part only a simple cubic 3D. 
I exported as model1.jt. I have only this option so i have no idea what is monolitic jt. 

So, NX created 1 model1.jt and 1 folder includes model1_2223.jt. This extra file. NX makes it for each solid model are included by 3D drawing.

 

Anyway. I created a new file and I give it a name: "model1.cojt". I think the problem is here, becasue I typed .cojt extension my self. 

After all I got same story, after defining the type and inserting component, I still no see the 3D image on graphic viewer. 

By the way, .Teamcenter mockup open my created jt files without no problem. 

Thanks. 

Re: insert own model as a part or resource

Siemens Genius Siemens Genius
Siemens Genius

Hi,

 

My bad with the Monolithic name, I am usually using NX integrated with TC and not NX standalone.  I didn't realize the File->Export options looked different. 

 

I created a video for you to help explain exporting JTs from NX and what is required to make a .cojt.  I still think this is where the problem is and hope it helps you out.  If not we can look at the PS side.

 

The video is named Creating NX Part For PS.7z