Showing results for 
Search instead for 
Do you mean 
Reply

where is the error

i need help with motionparameters.e file for fanuc

my robot fanuc lrmate_100i_rj3i_b

 

i have problems with upload

 

information from upload in process simulate

 

 location P11: ComputeManualRrsConfigString: wrong motionparameters.e file, number of joints with turns is 2, should be 3

 

 

motionparameters.e file

 

motion_space             space_karel;
use_config               use;
interpolation_type       interpolate_by_2;
speeds_given             given;
joints_coordination      end_together;
cart_speed_to_jnt_cnvrt  by_lim_jnt;
speed_lim_jnt            2000.0;
default_control_parm     2000.0;
react_on_speed_excess    recalc;
check_joints_speed       check;
joint_limit_in_cart      stop;
is_wait                  wait;
approach_vec    approach_z;
cart_max_lin_speed       2000.0;
cart_basic_lin_speed     2000.0;
cart_max_lin_acc         4000.0;
cart_basic_lin_acc       4000.0;
cart_max_lin_dec         5000.0;
cart_basic_lin_dec       5000.0;
cart_max_rot_speed       2.2689275;
cart_basic_rot_speed     2.2689275;
cart_max_spin_speed      2.2689275;
cart_basic_spin_speed    2.2689275;
cart_max_roll_speed      3.665191;
cart_basic_roll_speed    3.665191;
zone_define  fine no_smooth ;
zone_define  coarse speed cartesian 3.0 ;
zone_define  medium speed cartesian 50.0 ;
zone_define  nodecel speed cartesian 99.5;
zone_define  sp_zone1 speed cartesian 30.0;
config_family               cf_over_head_pos;
joint_config_family j3      joint_cf_elbow_up;
joint_config_family j4      joint_cf_pos;
joint_config_family    j5        joint_cf_pos;
default_turns         j1 0 -180,    j4 0 -180,    j6 0 -180;
joint_vel_prof      rot     const_time_prof ;

Kind regards,

Benjamin Voelzke
7 REPLIES

Re: where is the error

Your motionparameters.e file should have this:

 

config_family         cf_over_head_pos;
joint_config_family    j3      joint_cf_elbow_up ;
joint_config_family    j5      joint_cf_pos;
default_turns j1 0 -180.0, j4 0 -180.0, j6 0 -180.0;

Re: where is the error

after chaning i have the same error

 

Internal Error at file ABLEGEN.PE, operation ABLEGEN, location P1: ComputeManualRrsConfigString: wrong motionparameters.e file, number of joints with turns is 2, should be 3

 

 

motion_space             space_karel;
use_config               use;
interpolation_type       interpolate_by_2;
speeds_given             given;
joints_coordination      end_together;
cart_speed_to_jnt_cnvrt  by_lim_jnt;
speed_lim_jnt            2000.0;
default_control_parm     2000.0;
react_on_speed_excess    recalc;
check_joints_speed       check;
joint_limit_in_cart      stop;
is_wait                  wait;
approach_vec    approach_z;
cart_max_lin_speed       2000.0;
cart_basic_lin_speed     2000.0;
cart_max_lin_acc         4000.0;
cart_basic_lin_acc       4000.0;
cart_max_lin_dec         5000.0;
cart_basic_lin_dec       5000.0;
cart_max_rot_speed       2.2689275;
cart_basic_rot_speed     2.2689275;
cart_max_spin_speed      2.2689275;
cart_basic_spin_speed    2.2689275;
cart_max_roll_speed      3.665191;
cart_basic_roll_speed    3.665191;
zone_define  fine no_smooth ;
zone_define  coarse speed cartesian 3.0 ;
zone_define  medium speed cartesian 50.0 ;
zone_define  nodecel speed cartesian 99.5;
zone_define  sp_zone1 speed cartesian 30.0;
config_family         cf_over_head_pos;
joint_config_family    j3      joint_cf_elbow_up ;
joint_config_family    j5      joint_cf_pos;
default_turns j1 0 -180.0, j4 0 -180.0, j6 0 -180.0;
joint_vel_prof      rot     const_time_prof ;

 

Kind regards,

Benjamin Voelzke

Re: where is the error

you need to reopen the study and reupload the path

Re: where is the error

yes i'am starting ps again.

 

i make upload without rcs modul.

 

i think this is the problem.

 

 

Kind regards,

Benjamin Voelzke

Re: where is the error

If your motionparameters.e is correct, you should be able to upload without RCS module.

Re: where is the error

upload without RCS Modul is not possible.

 

i have the same error with all robot paths.

 

Smiley Sad

Kind regards,

Benjamin Voelzke

Re: where is the error

You are not changing the motionparameters.e that you think the system is reading. Or in you motion parameters, there is a still a turn definition with 2 joints only... I do not see any other reason.

With RCS, you can upload correctly even with a wrong motionparameters.e. Without RCS, the motionparameters.e should contain the lines I sent before for the definition of the config and turns.