New tachometer problems since update to V18


Background: we use Monarch PLT200 Laser Tachometers for many purposes.  In the past, I would simply attach the output from the laser tach to a SCADAS Tacho channel, and all was well, with a smooth tacho signal corresponding to actual speed and matching the digital read-out on the Monarch.  Everything worked perfectly, without any additional setup required.


Now: For some reason, since updating to V18 SimCenter, I do not have a smooth tacho signal.  I'm not sure if it's something I'm doing incorrectly, or if something must be set-up differently, but there's a huge difference, in the form of a noisy signal.


Today, I measured the raw signal output of the tacho, using other means, to see the voltage pulse vs time, and typically see this:

Tacho2.JPG Tacho Normal.JPG                                        With amplitudes: 


The flat line is ≈0.75VDC, the square wave plateau is ≈1.5VDC, and the peak is just over +3VDC.


LMS Test.Lab V16 never had a problem converting this pulse to tacho - no extra setup needed (crossing voltage, pulse correction, etc.).  We are only reading one pulse/rev., with a span of ≈500-12000RPM.


I have tried changing the tacho setup in Tracking, setting various Crossing voltages (+3VDC for instance to eliminate potential double-pulses), and even tried some pulse correction, but haven't been successful.


Now, I'm getting what I'm calling repeating noise in the conditioned tacho signal.




This photo is from Time Data Selection.  The highlighted portion should be a smooth signal at ≈4653 RPM.  I also tried Smoothing the signal using the Time-Signal Calculator, but needed to apply a smoothing factor of 0.9999 to make it close to smooth, and because of the dips in the signal below the real value, the calculated smoothed level is way too low.


And then, every so often while watching the live tacho signal on a Front/Back graph on the Measure tab, the measured signal will smooth right up and look great!  I have tried (3) different Monarch Tachometers, (2) different (and new) Monarch output cables, (2) different Siemens tacho LEMO cables, and (2) different Siemens SCADAS units, all with the same result.



Has there been a change for the new SimCenter, on how the software processes the raw tacho input? 


If not, can someone please give me alternative laser tachometer brands, with output capabilities, that have a cleaner signal? 


I have ordered one other brand, made by Advent Corp., but I won't receive it until next week Monday.  I'm so far behind on these projects, I'd be willing to order a couple more just to have a spare or two on the shelf.


Please let me know the Make/Model laser tachos that you are using with SimCenter.

Thanks everyone!



Update - I should add: the reason I have (2) brand new Monarch output cables on the shelf, is I have had bad luck with these cables in the past, and the connection to the Monarch hardware.  They use a stereo headphone jack.  I'm wondering if the tacho low (ground) is floating, which is why the flat-line of the raw signal is at ≈0.75VDC.  That's why I tried three different laser tachs.


Re: New tachometer problems since update to V18

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi Shelly,


This is probably more of a response line question since they can setup a Skype meeting to see your signal and help with processing.


Since our default cross (trigger) level is 0 volts that would trigger on the trailing edge downward spike which is is not ideal.  Looking at your signal wouldn't a trigger level of 1.0 or 1.25 volt on the positive side of the pulse be more appropriate?

If you want us to look at your data, can you either upload it here or email it the TEST support inbox?

Re: New tachometer problems since update to V18

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi Kevin,

I had received Shelly's data and working on it already.




Re: New tachometer problems since update to V18


Good morning Kevin.


I have been working with Hong on this problem, and uploading various raw data files for her to look at.


Initially, I had tried using different trigger levels due to the nature of the wave.  I thought that odd though, since the default parameters for a DC tacho used to work fine, without any changes.


Either way, she has been looking at various raw data files and tacho signals for us, and I have a different brand of laser tacho that's supposed to arrive today for us to try if we can't work out the Monarch issues.


Thank you!!

Re: New tachometer problems since update to V18


Update: I have received a new brand of laser tachometer, from Compact Instruments Co.  This sensor is working well.  I didn't review the raw tacho input, but looking at the input on the Tracking tab, it's a TTL square wave as advertised in the product's manual.  EDIT: this new tach has a LEMO cable output to BNC.  I feel more comfortable with this setup versus the 3.5mm stereo headphone adapter.


I initially attempted to use the new tacho with all default setup parameters, just like in the past with the Monarch, but that didn't work.  I indexed the trigger level up to 2VDC, and everything works well!


I am working overtime to get a few Order Analyses tests completed this week, and then I plan on sending one of our Monarch laser tachs to Hong, for her to check it out and see if she can determine what's up with the noisy signal.


Thanks all!