Showing results for 
Search instead for 
Did you mean: 

JT2Go Auto Update issue ... Now Fixed!

Siemens Legend Siemens Legend
Siemens Legend

The issue with auto update has been resolved, thank you for your patience. Users can now update their JT2Go versions through the auto update feature.


JT2Go users are experiencing an issue with the auto update feature. This is a known issue related exclusively to the auto update feature. Users wishing to migrate to 11.4 of JT2Go should download the latest release from the JT2Go website and perform the install manually.


Sorry about the inconvenience


Any ETA on the fix of this issue?   I'm fielding many user tickets here at GE Aviation.




We have just updated from ST7 to ST10 and but there is no stand-alone viewer for ST10.

I have downloaded and installed JT2GO for one of our users who just needs to view files.

It starts OK, but then we get an error trying to open a file -

"Error: Failed to get Service".

I didn't uninstall ST7 viewer if that makes any difference.

Siemens Phenom

We are actively working on a solution for the auto update problem.  We hope to have a solution in the next few weeks.

Siemens Legend

Regarding the Solid Edge file question, your errror doesn't sound like an error from JT2Go. Are you attempting to load .par or .asm files from a local drive?


The files are stored on our server.

I have removed JT2GO and installed View and Markup, which works ok.

Siemens Legend

We have resolved the issue with auto update, users will now be able to successfully complete an auto update from a previously installed version of JT2Go.



in my opinion, the error is still not resolved. On several clients with different JT2Go versions ( or earlier) I still get the error "Error retrieving update" and "C: \ Program Files \ Siemens \ JT2Go \ Products \ jt2go \ VisView.exe could not be found Make sure you entered the name correctly and try again ".
Is there Version 11.4 as a direct download, without having to go through the update function?

Siemens Phenom

The problem with "Error: Failed to get Service" is in Visual C++ 2013.

Version JT2GO 11.4 is installed with Visual C ++ 2015, but needs Visual C ++ 2013 :-( I've been worried about it for about two days, but I figured it was that.

excuse me english - google translator


Siemens Phenom

JT2Go 11.4 does not need VS C++ 2013.  It requires the VS 2015 redistributables.




nop.Výstřižek 2.JPGVýstřižek.JPG. I had a clean installation of the operating system for the problem. installed JT2GO 11.4 as I downloaded it and the problem "Error: Failed to get Service". I compared it with a PC where JT2Go worked and the difference was in Visual C ++ 2013.